PuzzleWizard Start Help

PUZZLE WIZARD 4

PuzzleWizard vi permette di costruire i vostri puzzle personali utilizzando le immagini che preferite o create da voi stessi.

Con pochi click del mouse avete modo di creare un simpatico e originale presente, inviando una vostra foto o una foto delle vostre vacanze agli amici che, oltre a vederla e poterla salvare, avranno modo di divertirsi con la stessa. Il tutto in un unico file eseguibile di dimensioni estremamente ridotte che potete spedire via mail. PuzzleWizard, inoltre, è un programma multilingue sia in fase di creazione che di distribuzione. Utilizzate PuzzleWizard anche per mandare gli auguri... un modo nuovo e unico per farvi ricordare!

Creare un puzzle

Giocare con il puzzle

Requisiti minimi d sistema:

Pentium® II 266MHz o equivalente
Microsoft® Windows® 98 SE o superiore
Risoluzione grafica minima 800 x 600 (consigliata 1024 x 768)
Modalità colori video: 24 bit (true color) o superiore

PuzzleWizard © 2000 - 2003 by:

Claudio Gucchierato

Mauro Rossi


PuzzleWizard - Guida in linea

Autocomposizione Puzzle

L'interfaccia del programma di autocomposizione puzzle è semplice e la costruzione del proprio puzzle richiede solo poche informazioni di base.

Il programma comprende due linguette (schede), di cui la prima è quella preposta alla costruzione dell'applicazione.

spunta.gif (385 byte) Pulsante "Seleziona immagine": innanzitutto va selezionata l'immagine che si vuole usare per costruire su di essa il puzzle attraverso questo pulsante. Per un risultato ottimale si consiglia di selezionare immagini di dimensioni 360x360.

spunta.gif (385 byte) Pulsante "Anteprima": vi si aprirà una finestra in cui potete vedere un'anteprima dell'immagine selezionata e di come la stessa verrà presentata nel puzzle. Se l'immagine selezionata è di dimensioni superiori o inferiori a 360x360 (misurati in pixels), la stessa risulterà essere deformata. La finestra di anteprima vi da modo di ridimensionare automaticamente l'immagine, attraverso un piccolo editor interno.

spunta.gif (385 byte) Casella "Visualizza la griglia delle tessere del puzzle": tale casella di spunta permette di visualizzare o meno il modo in cui l'immagine verrà scomposta in tessere nel puzzle finale.

spunta.gif (385 byte) Casella "Ridimensiona 360x360": se questa casella è spuntata e successivamente viene premuto ridimensiona, l'immagine verrà rielaborata in automatico e ridimensionata 360x360 prelevando la parte centrale dell'immagine scelta. Se tale casella non è spuntata verrà prelevata e ridimensionata la parte in alto a sinistra dell'immagine e ridotta sempre a 360x360.
L'immagine così ridimensionata verrà automaticamente salvata in formato compresso JPG e caricata come predefinita nell'autocomposizione del puzzle. Nel caso non interessasse l'utente potrà riselezionare un'altra immagine.
Se l'immagine scelta è in formato BMP e di dimensioni uguali o inferiori a 360x360, apparirà un pulsante "Salva in JPG" che permetterà di comprimere e salvare in formato compresso l'immagine stessa, nonché di caricarla automaticamente nell'autocomposizione.

spunta.gif (385 byte) Pulsante "Inserisci testo": potete inserire un testo che farà da "cappello" al vostro puzzle (una dedica, una spiegazione o una frase qualunque). Tale frase non può superare i 100 caratteri e non possono essere inseriti salti di riga o segni di "a capo".

spunta.gif (385 byte) Casella "Seleziona lingua del puzzle": potete selezionare la lingua in cui appariranno le didascalie nel vostro puzzle finale tra le cinque messe a disposizione (Italiano, Inglese, Francese, Spagnolo e Tedesco).

spunta.gif (385 byte) Casella "Nome del file eseguibile": in questa casella potete inserire il nome che volete assegnare all'eseguibile finale (senza estensione che sarà predefinita come EXE)

spunta.gif (385 byte) Pulsante "Salva in...": potete selezionare in quale cartella o drive salvare il puzzle autoestraente così realizzato. Le etichette indicano sia il percorso selezionato che la grandezza totale del vostro puzzle.

spunta.gif (385 byte) Pulsante "Crea puzzle": inserite le informazioni di cui sopra, attraverso questo pulsante viene fisicamente realizzato e creato il puzzle finale.

spunta.gif (385 byte) Pulsante "Annulla": per eliminare le informazioni inserite e ripristinare la situazione di default.

Nella seconda linguetta (scheda), oltre le informazioni sul programma e gli autori, è presente una casella a discesa per poter selezionare la lingua dell'interfaccia per l'autocomposizione puzzle, tra le cinque disponibili: Italiano, Inglese, Francese, Spagnolo e Tedesco.

Home PuzzleWizard © 2000 - 2003 by Mauro Rossi & Claudio Gucchierato


PuzzleWizard PUZZLE - Guida in linea

PUZZLE

Giocare e utilizzare PuzzleWizard è estremamente semplice e divertente... per saperne di più, leggete queste semplici istruzioni e/o spiegazioni e buon divertimento!

Pulsanti per la scelta del grado di difficoltà.

Questi tre pulsanti servono per impostare il grado di difficoltà nella risoluzione del puzzle.

Semplice : mette a disposizione un tempo di 5 minuti con la versione a 36 tessere, o di 3 minuti con la versione a 16 tessere, per la risoluzione del puzzle, inoltre maschera in modo lieve l'immagine campione di riferimento.

Medio: mette a disposizione un tempo di 4 minuti con la versione a 36 tessere, o di 2 minuti con la versione a 16 tessere, per la risoluzione del puzzle, inoltre inverte i colori dell'immagine campione di riferimento.

Difficile: mette a disposizione un tempo di 3 minuti con la versione a 36 tessere, o 1 minuto con la versione a 16 tessere, per la risoluzione del puzzle, inoltre non viene visualizzata l'immagine campione di riferimento.

Pulsante tessere

tessera.gif (215 byte) Questo pulsante consente di selezionare la versione del puzzle a 36 o 16 tessere (adatta ai bambini più piccoli)

Pulsanti Opzioni

Include o esclude il timer. Con il timer escluso il gioco può continuare all'infinito ma, non sarà mai possibile salvare i tempi dei risultati raggiunti.

Include o esclude i suoni. Consente di abilitare o disabilitare gli effetti sonori.

Inizia un nuovo gioco.

Consente di cambiare e personalizzare il colore dello sfondo.

Consente di visualizzare le tessere del puzzle con l'effetto tridimensionale (bordo evidenziato) o normale (nessun bordo).

Consente di inserire una pausa durante il gioco e fermare, se abilitato, il timer di conteggio del tempo.

Barra per la visualizzazione del tempo trascorso/rimasto.

Con timer abilitato, la barra visualizza graficamente e numericamente sia il tempo trascorso e si a il tempo residuo. Con timer disabilitato viene visualizzato solo il tempo trascorso.

Consente di salvare nel driver prescelto (disco, floppy, ecc.) una copia dell'immagine del puzzle. Questo pulsante è disponibile all'interno della finestra che viene visualizzata alla fine di ogni gioco.

E adesso ...come giocare!

Dopo aver impostato le opzioni preferite (grado di difficoltà, numero di tessere, suoni e timer) premendo il pulsante centrale [image] inizierà un nuovo gioco.

Scopo del gioco, come per qualunque puzzle tradizionale, è ricostruire nel minor tempo possibile l'immagine scomposta nelle varie tessere. Per spostare e posizionare le tessere occorre posizionare il cursore del mouse sopra alla tessera da spostare, premere il pulsante sinistro del mouse e, tenendolo sempre premuto, trascinare la tessera nella posizione voluta. Rilasciando il pulsante viene rilasciata anche la tessera selezionata. Se la posizione del rilascio della tessera è corretta, la tessera viene posizionata e bloccata automaticamente; in caso contrario la tessera ritorna nel punto dal quale è stata prelevata.

Alla fine di ogni partita vengono confrontati i tempi impiegati nella soluzione del puzzle relativamente al livello e al numero di tessere selezionato. Se il tempo impiegato è inferiore a quello memorizzato nei giochi precedenti, viene visualizzata la maschera per la registrazione del "record" ottenuto. Qesta registrazione verrà visualizzata, assieme al tempo impiegato, ad ogni successiva partita.

Home PuzzleWizard © 2000 - 2003 by Claudio Gucchierato & Mauro Rossi